Microsoft Server Cluster Service – An error occurred attempting to move the group. The cluster node was not found. Error ID 5042


Since restarting all the server nodes in a MSCS cluster I had an issue with a couple of the server nodes reporting delayed write errors to a drive that should have only been visible to one of the nodes.

I tried to move the cluster group to the server node that should not have access so that I could then move it back to the correct node thinking that it would potentially cleanly remove the access to the drive resource. When I tried to move it I got the error:

An error occurred attempting to move the group. The cluster node was not found. Error ID 5042

After a bit of a search found this http://kbalertz.com/263317/Error-Message-Moving-Group-Another-Cluster.aspx which helped.

I checked that the resource group was configured to move to the node which it was but the individual resource elements in the group where not! Adding the server node as a destination for each of the resources allowed me to then move the group to and from the offending server node and stopped the write delay errors.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s